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How to add a dropdown list to a cell

You can create a simple list control for your users in a sheet. Doing so reduces errors by limiting input from
the keyboard and facilitates input tasks for your users. Adding the control to an Excel sheet isn’t intuitive; the

option is in the Data Validation feature. Fortunately, once you know the feature exists, it's easy to implement.

You need only two things: a list and a data entry cell. Figure A shows a simple dropdown list in an Excel
sheet. Users click the dropdown arrow to display a list of items stored in A1:A4. If a user tries to enter some-

thing that isn’t in the list, Excel rejects the entry (by default).

A A | B | | D | E F
17cat

2 dog

3 |horse

4  bird cat

— dog

57 horse

6 bird

Figure A: You can use this list to populate a list control for easy
data entry.

To add this dropdown list to a sheet, do the following:

1. Create the list in cells A1:A4.

2. Select cell E3, the data entry cell.

3. Click the Data tab.

4. Click the Data Validation option in the Data Tools group.

5. Choose List (Figure B) from the Allow option’s dropdown list.

Data Validation ? x

Settings  Input Message  Error &Alert

Validation criteria

Allow:

Any value ~ | ' lgnore blank

Any value
Whale number
Crecimal

List

Date

Time

Text length
Custom

Apply these changes to all other cells with the same settings

o [

Figure B: Choose the list option.
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6. Click the Source control and select cells A1:A4 (Figure C). Alternately, simply enter the reference
=$A$71:$A%4. Make sure the In-Cell Dropdown option is checked. If you uncheck this option, Excel still

forces users to enter only list values, but it won’t present a dropdown list.

7. Click OK.

Data Validation ? X

settings  Input Message  Error Alert

WValidation criteria

Allow:

|List [~ Ignore blank
Data: E‘ln—cell dropdown
|between v|

Source:

[=sastsasa

Apply these changes to all other cells with the same settings

[ ok ]| conce

Figure C: Identify the list items.

Users click the dropdown and choose an item to enter a value into cell E3, and E3 equals the selected value. It

couldn’t be simpler!

Notes

It’s worth pointing out that the dropdown arrow is visible only when the cell is active. To make the control
easier to use, consider applying a fill color or border to the cell. If you believe users will need more information,
explore the Input Message and Error Alert options. In addition, if you use this feature in a Table, Excel will

automatically copy the control to new rows.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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Build a dynamic chart using a Table
object

If you want to advance beyond basic spreadsheet skills, creating dynamic charts is a good place to begin that
journey. The key is to define the chart’s source data as a dynamic range. By doing so, charts based on that
data will automatically reflect changes. Fortunately, this is easy to accomplish if you’re willing to use the Table

feature (available in Excel 2007 and later).
First, convert a data range into a Table as follows:

1. Select the data range. Using the data set shown in Figure A, you’d select A1:ES3.

2 |January 4213 4796 2149 4611
3 February 3194 1449 9020 7402,

Figure A: Convert the data range into a Table.

2. Click the Insert tab.

3. Inthe Tables group, click Table.

4. If the Table doesn’t have headers, be sure to uncheck the My Table Has Headers option.

5. Click OK, and Excel will format the data range as a Table.

Any chart you build on the Table will update automatically. To illustrate this efficient behavior, create a quick
column chart as follows:

1. Select the Table.

2. Click the Insert tab.

3. Inthe Charts group, choose the first 2-D column chart in the Chart dropdown to create the simple column

chart shown in Figure B.

A A B € D E F G H |
Ll Month g Smithg Jonesg Michaelsy Hancockg .

2 January 4213 479 2149 4611 Chart Title

3 |February 3194 1449 9020 7402 10000

4 | 8000 :
5 6000 i
6 4000 i B
7— 2000 I i I ‘

8 ) | -1 | |
97 January February

10

1 mSmith mJones ® Michaels m Hancock

Figure B: Base a column chart on the data.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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Now, update the resulting chart by adding values for March, as shown in Figure C and watch the chart

update automatically.

Fole [ow [
2 January 4213 479% 2149 4611 Chart Title
'3 February 3194 1449 9020 7402 10000
4 |March 2010
5
6
7
8

January February March

mSmith mJones m Michaels ®m Hancock

19

Figure C: The chart updates automatically.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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Count the number of records that fall
between two dates

Many records include a date stamp of some sort. Usually the 5 B 1| oA A R A g
date marks an event or the record’s input date. Fortunately, 4 A 8 c | b
1 |Beginning Date 11/9/2016
counting the number of records that fall between two dates 2 |Ending Date 11/10/2016
) ) ) ) ) 3 |Total Records 2
is easy using the COUNTIFS() function. We can illustrate this 4 |Date Personnel sold
technique using the simple sheet shown in Figure A. Sl 11/10/2016)Susan 73
6 | 11/9/2016 Alexis 26
7| 11/12/2016 Alexis 75
The formula in cell B3: 8 |  11/11/2016 Kate 19
9 | 11/12/2016 Bill 33
B . v o . N 10| 11/12/2016 Susan 25
=COUNTIFS(A5:A12,">="&B1,A5:A12,"<="8&B2) 1| 11/12/2016 Kate =
12 | 11/12/2016 Bill 87

returns the number of dates (records) in A5:A12 that fall between
) Figure A: We’ll count records between date
the dates entered in B1 and B2. values in the Date field.

The COUNTIFS() function uses the following syntax to specify

multiple criteria to determine which values in a range to count:
COUNTIFS(countrangel, criterial, [countrange2, criteria2]...)

In this example, the count range is the same for each criteria set, the dates in column A. The first criteria set
counts all the dates in A5:A12 that are equal to or fall after the date value in B1. The second criteria set counts

dates that are equal to or occur before the date value in B2.

The only stipulation with this particular setup is that the value in B1 must be less than the value in B2. If you
enter them backward, the function will return O instead of an error. To apply a conditional format to alert your
users, do the following:

1. Select B2.

2. Click the Home tab and then click Conditional Formatting in the Styles group.

3. Choose New Rule.

4. Choose the Format Only Cells That Contain option.

5. Choose Less Than from the second dropdown.

6. Enter =$B$17 in the expression control.

7. Click Format.

8. Click the Fill tab, choose a background color, and click OK. Figure B shows the rule, expression, and

format.

9. Click OK to return to the sheet.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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New Formatting Rule ? >

Select a Rule Type:

= Format all cells based on their values

= Format only cells that contain

= Format only top or bottom ranked values

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Edit the Rule Description:

Format only cells with:
iCeIIVaIue Eil ilessthan EII |=5E~S1 |ERE

G _ Fomet:

Figure B: Use a fill color to highlight an input error.

| ok || canc

The format won't stop a user from entering an incorrect date, but it will alert them that the value isn’t

appropriate, as shown in Figure C.

B3 - = fe =COUNTIFS(A5:A12,">="8&B1,A5:A12,"<="&B2)
A ‘ B L e | B

1 |Beginning Date 11/9/2016

2 |Ending Date

3 |Total Records 0

4 |Date Personnel Sold

5|  11/10/2016 Susan 73

6 11/9/2016 Alexis 26

77 11/12/2016 Alexis 75

8 | 11/11/2016 Kate 19

9_ 11/12/2016 Bill 33

10_ 11/12/2016 Susan 25

11 | 11/12/2016 Kate 82

127 11/12/2016 Bill 87

Figure C: A conditional format warns users when
the date in B2 is less than the date in B1.
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How to sum values in a filtered list

Filters offer a powerful and easy-to-use way to limit data to specific records. To sum a filtered set, you can try

a SUM() function, but you might get a surprise—well, | can promise you'll get a surprise. Figure A shows a

filtered list. Specifically, the filtered list displays only those records where the Unit Price value is greater than or

equal to 50.
EA7 = S | =SUM(E3:E33)
A B C D B G H
_1 D E2 Prod ame - Price - o - On Orde Ei Re B4 Catego -
3 |} 3 Aniseed Syrup. $10.00 i it 25 CrmliiEnis
13 | §31 Gorgonzola Telino $12.50 0 70 20 Chips, Snacks
15 37 Gravad lax $26.00 11 50 25 Canned Fruit & Vegetables
33 | | 45 Regede sild $9.50 5 70 15 Soups
i | 380/~

Figure A: You can tell by the row numbers to the left that many rows are hidden.

Our technique uses the Table object’s filtering behaviors. If you don’t want to use a Table, you can filter records

using Excel’s built-in filtering feature on the Data tab in the Sort & Filter group.

Before we look at SUM()’s limitations when working with filtered lists and how to avoid those limitations, let’s

quickly review the data. First, the data is formatted as a Table object (available in Excel 2007 and later). To

convert a data range to a Table, do the following:

1. Click anywhere inside the data range.
2. On the Insert tab, click Table in the Tables group.

3. Inthe resulting dialog, uncheck or check the My Table Has Headers

Create Table 7 x
Where is the data for your table?
|-SAS1:5G546
[+] My table has headers
[ ok ] conca |

option (Figure B).

Figure B: Convert a data range into

4. Click OK. a Table.

To achieve the result shown in Figure A, apply the following filter:

1. From the Units On Order dropdown, choose Number Filters and then select the Greater Than Or Equal To
option (Figure C).

2. Inthe resulting dialog, enter 50 (Figure D) and click OK.

3. Incell E47, enter a SUM() function for E3: E33 (if you drag) and E3:E46 if you enter the references
manually.

You can tell that the result isn’t correct; the value is too high—but why? The SUM() function is evaluating all the
values, not just the filtered values. There’s no way for the SUM() function to know that you want to exclude the

filtered values in the referenced range.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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B D E F G
Unit Price ﬂ Units In Stock [l Units On Order n Reorder Level HCatEgow hd
2] Sort Smallest to Largest 0 Beverages
zl T i 25 Condiments
B Sl s LS 30 Canned Fruit & Vegetables
Sort by Color » 0 Candy
- 10 Beverages
s : 25 Condiments
Filter by Colo 5 Canned Fruit & Vegetables
Mumber Filters L4 Equals... ;
getables
|Search p: Does Mot Equal... ixes
Greater Than...
Greater Than Or Equal To...
Less Than... getables
Less Than Or Egual To...
Between...
Top:1d:- _-getables
Above Average getables
Below Average F
| oK | | Eanel : getables
] Custom Filter... ixes
S3LUU y i 25 Baked Goods & Mixes
Figure C: Choose a filter.
Fortunately, there’s more than one solution. First, click
Custom AutoFilter 7 ®
AutoSum in the Editing group on the Home tab. As
Show rows where:
you can see in Figure E, Excel automatically enters BOE e Sl
. . . |is greater than or equal to EI |50
a SUBTOTAL() function instead of a SUM() function.
® ana O or
This function references the entire list of values, but it | El |
evaluates only the filtered values. Use 7 to represent any single character
Use * to represent any series of characters
| ok || cancer |
Figure D: Enter the criteria.

Example.xlsx - Excel Table Tools

H Data Review View Developer Design Q Tell me what you want to do

N — £~ E—PWrapTent General z Y ;
s E== == EHMm & Cent - el Conditional Foermatas Cell Insert Delete Format Sort & Fin
- == E Merge & Center 35 e Formatting ~ Table~ Styles b - b & Clear~ Filter ~ Sele
P Alignment ] Mumber [P Styles Cells Editing
109,[Units
C D E F G H |
Unit Price B3 Units In Stock 3§ Units On Order [Ej§ Reorder Level [EJ Category [~ |
$10.00 13 70 25 Condiments
$12.50 0 70 20 Chips, Snacks
$26.00 il 50 25 Canned Fruit & Vegetables
$9.50 5 70 15 Soups
260| -] ]

Figure E: SUBTOTAL() knows to evaluate only the visible values in a filtered set.
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There’s a second way that’s a bit cleaner: Use the Table’s Total Row. Before you do, delete the SUBTOTALY)
function in E47 and clear the filter. Adding the Total Row is simple:

1. Click anywhere inside the Table.

2. Click the contextual Design tab.

3. Inthe Table Style Options group, check Total Row (Figure F) and Excel will expand the Table. Look for the

thin blue line surrounding the new row.

&h o= Exampleads: - Bxcel bl T Susan Hark]

CICE

File

= 0

Home Insert Page Layout Formulas Data Revview View Developer

Table Mame: Summarize with PivotTable o= [ | Header Bow First Column

Table3 B8l Rernowe Duplicates "\“| l'_") ...laﬂ Column =
= y . Insest | Export Refrech . =~ eSee————C - |EEEEE EEEEE] EEEEE
¥ Resize Table = G Convert to Range Shicer . - €23 Unlink +| Banded Rows Banded Columns
Properties Taals External Table Data Table Style Options Table Styles
F& X § 10
AIIDJProduct Name Lli.lnil Price JUni'rs InStock |- |Units On Order | - |Reorder Level | -|Category [-] H
38 | 20 Sir Redney’s Marmalade $81.00 40 0 0 Grains
39 | 21 Sir Rodney's Scones $10.00 3 40 5 Pasta
40 | 46 Spegesild $12.00 95 0 0 Soups
41| 35 Steeleye Stout $18.00 20 0 15 Canned Fruit & Vegetables
42 | 19 Teatime Chocolate Biscuits 59.20 25 0 5 Dried Fruit & Nuts
43 | 29 Thiiringer Rostbratwurst $123.79 0 o 0 Beverages
44 | 14 Tofu §23.25 35 0 0 Beverages
45| 23 Tunnbrad SRRV T = P
bl Bob's Organic Dried Pears $30.00 15 0 10 Dried Fruit & Nut>
.ﬁ\_
49 |

Figure F: Display the Total Row.

4. Choose Sum from the Units On Order dropdown (Figure G). Each cell in the Total Row offers this drop-

down. Evaluating the entire data set, the function returns 420.

E47 T & =SUBTOTAL({103,[Units
A A B C D E F G
1D B Product Name B3 Unit Price B Units In Stock |3 Units On Order Reorder Level [J Category

3 | 3 Aniseed Syrup $10.00 13 70 25 Condiments
1?; 31 Gorgonzola Telino $12.50 0 70 20 Chips, Snacks
15: 37 Gravad lax $26.00 11 50 25 Canned Fruit & Vegetables
3_37 45 Regede sild $9.50 5 70 15 Soups
47 L a60f
48_
£ |
50

Figure G: Select a function.

5. Apply the filter you used earlier (>=50) and the function automatically updates, displaying the same results
you saw in Figure E. If you check the Formula bar, you'll see that Excel entered SUBTOTAL(), not SUM().

Excel is smart enough to anticipate your needs.

Copyright ©2016
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Hide everything but the working area
in an Excel worksheet

You usually hide a column or row to conceal or protect data and formulas. But you can also hide unused
regions of a sheet to keep users from exploiting those areas or to help them stay on task by preventing them
from wandering. By inhibiting access to unused rows and columns, you present a sheet that focuses on just
the work area. To demonstrate, we’ll use the sample worksheet shown in Figure A, which has a small working

area and a lot of unused rows and columns.

11/7/2016 | 8:00 AM 6:00 PM
11/8/2016 | 10:00 PM 7:00 AM
11/9/2016 | 8:00 AM 6:00 PM
11/10/2016| 8:00 AM 5:00 PM
11/11/2016| 8:00 AM 5:00 PM
11/12/2016
11/13/2016

O e N s W N =

=
| [=]

Figure A: Let’s inhibit access to unused areas of this sheet.

Before you hide anything, make sure you don’t inadvertently hide an obscure work area. To find the last cell in

the sheet’s used range, press Ctrl + End. If you find anything, deal with it before hiding that area.

When ready, hide unused rows as follows: =

4 Share
, EE=3 i | = = D AutoSum v A
1. Select the row beneath the sheet’s last iy [ | &= B F_:v i S )
Formatas Cell Insert Delete Format : Sort & Find &
used row. (Select the row header to SR e | TR i | @ Clear- e s
. Styles Cells | Cell Size e
select the entire row.) In our example
I[ Row Height... 3
sheet, select row 9. AutoFit Row Height
_ I J T3 columnWidth.. L M i
2. Press Ctrl+Shift+Down Arrow to select AutoFit Column Width
every row between the selected row Default Width...
d the bottom of the sheet S -
an e bottom of the sheet. e g T
i ; Organize Sheets -
3. On the Home tab, click Format in the B Ehide Colamrs
Rename Sheet Hide Sheet
Cells group. Move or Copy Sheet... Unhide Rows
Tab Color 3 =
X = Unhide Columns
4. From the dropdown, choose Hide & S “
Unhide and then choose Hide Rows 7 Protect Sheet..
. [ Lockcen
(Flgure B) Format Cells...
| I

Figure B: Choose the Hide format.

Copyright ©2016
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5. Repeat this process to hide unused columns, only select the column header in the first empty column.
6. Press Ctrl+Shift+Right Arrow.
7. Choose Hide Columns from the Format dropdown’s Hide & Unhide option.

Figure C shows the resulting sheet. The only cells users can select are those visible in the sheet.

y | A | BB C | D | E |
1

2 117712016 | 8:00 AM 6:00 PM  0:00 [ 0MN
3 [11/8/2016 |10:00PM 7:00AM 1:00  8:00
4 11/9/2016 | 8:00AM 6:00 PM  0:00

5 [11/10/2016| 8:00AM 5:00PM  0:00

6 [11111/2016| 8:00AM 5:00PM  0:30

7 [111212016 0:00
8 111312016 0:00

Figure C: Hide unused rows and columns.
To unhide rows and columns, select the entire sheet. Then, do the following;

1. Click the Home tab.
2. Choose Hide & Unhide from the Format dropdown.

3. Choose Unhide Rows and Unhide Columns appropriately.

To complete the picture, you might also want to turn off the gridlines. To do so, uncheck Gridlines in the Show/
Hide group on the View tab. With the extraneous rows, columns, and gridlines hidden, you present a cleaner,

less busy interface for your Excel users. In short, users have fewer options to distract them.

Sometimes user tampering causes trouble and you’re the lucky one who has to make things right again. But

seeing only the actual spreadsheet cells tells users this isn’t an ordinary workbook. Instead of seeing a canvas
they can alter, they see a custom application. They do their work, and they move on. Be aware, however, that
a user who knows how to unhide the rows and columns can quickly get around this tactic. Don’t apply it as a

true security feature because it isn’t.

Copyright ©2016
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Using Excel’s FIND() and MID()
functions to extract a substring when
you don’t know the start position

Excel’s string functions provide a way for returning characters and subsets from an existing string. For
instance, using LEFT(), you can quickly return the first n characters in a string. Similarly, with RIGHT(), you
can return the rightmost n characters. MID() returns n characters from a specific starting position. The
functions rely on consistency. When that’s missing, consider combining FIND(). To demonstrate, I'll show you
how to combine FIND() and MID() to return characters from the middle of the string when the start point is

inconsistent.

About the functions

Before we start building parsing expressions, let’s quickly review the functions we’ll use: MID() and FIND().

Excel’s MID() function requires three arguments and uses the following syntax:

MID(text, start, num)

where text identifies the whole string, start denotes the position of the first character to return, and num
specifies the number of characters to return. In other words, MID() returns characters from a string by
specifying the first character’s position and the last character by its relationship to the first character.
Excel’s FIND() function has two required arguments and uses the following syntax:

FIND(findtext, withintext, [start])

where findtext is the substring you want to find, withintext is the text you're searching, and the optional
start argument specifies the character at which to start the search. If omitted, start is 1, the first character in

withintext.

Use FIND() to generate MID()’s

. A B
start point %soum
Knowing that the substring always begins with a certain position makes 2 K2445-B2100
it easy to use the MID() function. For example, MID(text, 4, 3) will always 3 K-B3150
return three characters starting with the fourth character in text. But - LEEEaEYE
what do you do when the substring could start anywhere? As long as > |K252-84100

6 |K25001-B4250

there’s something in the string that identifies the start of the substring—an 7 |k266221-B4250
anchor—you can combine FIND() and MID() to accomplish the mission. If E K26-B4250
the MID() function’s start position is unknown or inconsistent, use FIND(). Figure A: MID() alone can’t return

the first two characters following the

To illustrate this technique, we’ll use a simple expression to return the hyphen character for each string.

first two characters following the hyphen in the variable-length strings

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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shown in Figure A. It’s impossible using only MID() because

B2 bl fe | =FIND{"-",A2)
the hyphen’s position is inconsistent. A | B |
1 |SOURCE
Here’s the trick: Use FIND() to return the position of the hyphen 21 K2445-B2100 I:‘
in the string and then use that result as the MID() function’s 3 |K-B3150 2'
start argument. Figure B shows a simple FIND() function at 4_ K24112-B3175 7
work. 5_ K252-B4100 5
6 K25001-B4250 7
To achieve this result, enter the function: 7_ K266221-B4250 8
_FIND("-",A2) 8_ K26-B4250 4
Figure B: FIND() returns the position of the
into cell B2 and copy it to B3:B8. To extract the first two hyphen in each of the strings in column A.

characters that follow the hyphen, we add 1 to FIND()’s result.

So the expression:

cz = fe || =MID(A2,FIND{"-",A2)+1,2)
=Mid(A2,Find("-",A2)+1,2) A | B | c
returns the first two characters following the 1_ SOURCE
. - 2 |K2445-B2100 6|B2
first hyphen, as shown in Figure C. i

3_ K-B3150 2(B3

4_ K24112-B3175 7/B3

5_ K252-B4100 5B4

6_ K25001-B4250 7|B4

7'_ K266221-B4250 8|B4

Figure C: MID() uses the result of a FIND() function as its start
argument.

Copyright ©2016
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How to suppress O values in a chart

Charting Os isn’'t wrong, but you won’t always want to display O values in charts. Your data and the chart’s
purpose will guide you in this decision. When you don’t want to display these values, you have a few choices,

and some work better than others. We'll review a few that offer quick but limited results with minimum effort.

About the example data

Figure A shows the data and initial charts we’ll use throughout this article. Right now, the charts display O
values. These techniques are autonomous; if you use the same data set, be sure to undo each solution before
you start the next. Simply close the file and reopen without saving. (If you’re using an earlier version, your

results might vary.)

i

A
\

b S
a5

TR

b3

[\

A A | B | ¢ | D | E Vendor 1 Vemar 1
1 |Month  Vendor1 Vendor2 Vendor3| -
2 |January 13 100 95 ]\
3 |February 40 40 45 / \
4 |March 19 20 50 s
5 |April 0 30 75 ey L
& |May 19 0 40 oy / \ G
E“‘me 20 75 10 l;‘; / ﬂ\ f_—
8 [luly 13 20 0 4 \
9 |August 32 15 20 \ /
10
Azt i

£

i W

™,
............ £ e e ] e e ey e - S

Figure A: We'll use this sample data set and these charts.

The pie and single line charts reflect the data in column B for Vendor 1. The other two charts have three series:
Vendor 1, Vendor 2, and Vendor 3. This setup simplifies all the examples. Now that you’re familiar with the

example data, let’s review a few methods for suppressing the O values in our example charts.

Easiest but limited

You might try removing O values altogether if it's a literal O and not the result of a formula. Unfortunately, this
simplest approach doesn’t always work as expected. The stacked bar responds well to this solution. The pie
chart doesn’t chart the missing 0Os, but the legend displays the category label. Neither line chart handles the

missing Os well. If you removed the 0 values in the sheet, reenter them before you continue.

Copyright ©2016 CBS Interactive Inc. All rights reserved.
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Hiding the Os

You can try hiding the Os; there are two ways. First, try disabling the Show A Zero In Cells That Have Zero
Value option as follows:

1. Make sure the sheet with the charted data is active.

2. Click the File tab and choose Options.

3. Choose Advanced in the left pane.

4. Inthe Display Options For This Worksheet section, choose the appropriate sheet from the dropdown

menu.
5. Uncheck the Show A Zero In Cells That Have Zero Value option (Figure B).

6. Click OK. The 0 values still exist, and you can see them in the Formula bar, but Excel won’t display them.

Excel Options ? x
General E
Formulas Display options for this workbook: | ExcelSuppressODe.. ~
Proofing Show horizontal scroll bar
5 Show vertical scroll bar

ave
Show sheet tabs
AT Group dates in the AutoFilter menu
Advanced For objects, show:

® Al
() Mothing (hide objects)

Custemize Ribbon

Cuick Access Toolbar

Add-ins Display options for this worksheet: | EE& Data S

Trust Center Show row and column headers

[] Show formulas in cells instead of their calculated results
[] Show sheet right-to-left

1.k _

pm——__ n

< [ Show a zero in cells that have zero value!

N | ;
T S ———— SEETS plied

Show gridlines

Gridline color 8y -

Figure B: Uncheck this option.

This method has little to no impact; the chart treats the 0 values as if they’re still there, because they are. Be

sure to reset the option before you continue.
You might also try using the following format that hides Os:

1. Select the data range.
2. Click the Number group’s dialog launcher (Home tab).
3. Inthe resulting dialog box, choose Custom from the Category list.

4. Inthe Type control, enter 0,0;;; (Figure C).

Copyright ©2016 CBS Interactive Inc. All rights reserved.




BUILD YOUR EXCEL SKILLS WITH THESE 10 POWER TIPS

Review View Developer Q Tell me what you want to do
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0 & Cut Calibri - - AN == - EWapTet Mumber -
ER Copy ~
Paste I U~ rmat as
- ~ Format Painter g Format Cells [ X fable~
Clipboard ] Font les
Number  Alignment Font Border Fill Protection |
B2 - E f 13 LCategory: |
| | General Sample
A A | B | ¢ | D E Mumber 13 N
1 |Month  Vendorl Wendor2 Vendor 3 Currency
Accounting m
2 [sanuary 13 100 95 Date < = Y
Time il
fl February gu =Y =5 Percentage T — A
4 |March 19 20 50 Fraction 0
=) 2 Scientific 0.00
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6 |May 19 1] 40 SE ecial ##£0.00
< | ##80 );(# #20)
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8 |July 13 20 1] # #£0,00_);(# #£0.00)
= £ #£0,00_):[Red](#,#£0,00)
9 |August 32 15 20 5k 220 (55, ££0)
10 | §#,#£0 ); [Red](5#,#£0) i
1)
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15._ Type the number format code, using one of the existing codes as a starting point.
ik
15|

Figure C: Enter the custom format code.

5. Click OK. The stacked bar, shown in Figure D, is the only winner.

= anda 3

mnder 2
e 1
| I I
| I I

Sanuary Fabnsary tarch hprd Play June iy Aug st

4

Figure D: This technique works for the stacked bar chart.

These techniques are easy to apply. It won’t hurt to try them first, but don’t expect a panacea for every chart.

Remove the custom format before you continue.
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Charting a filtered data set

If you have a single data series, you can filter out the O values and chart the results. Like the methods
discussed above, it's a limited choice. Use it when it works—just know that it won’t always work. We can

illustrate this technique by adding a filter to the Vendor 1 column:

1. Click inside the data range.
2. On the Data tab, click Filter in the Sort & Filter group.
3. Click Vendor 1’s dropdown and uncheck O (Figure E).

4, Click OK to filter the column.

H ©- = 0 & s ExcelSuppress0Demo.xlsx - Excel
File Home Insert Page Layout Formulas Review View Developer D Tl u want to dd
[EFrom Access [ Show Queries [=] Connections | | [TT3 Y ok lear
3| E - e o T
[é From Web From Table E Properties Ve | apply
From Other Existing New Refresh zl Sol Filter
(B From Text Sources~  Connections  Query~ [EaRecentSourcs All- [ Edit Links A Yopidvanced Ci
Get External Data Get & Transform Connections a1
Bl ~ . J& || Vendorl
1 |Month E|Vendor :ElVendor 2. Vendor 3.
2] SortSmallest to Largest 100 95
El Sort Largest to Smallest
Sort by Color 4 40 45
%, Cion Fiter From “Vendor 20 50
hilter by C 30 75
Mumber Filters 3
0 40
|S&arch ﬁ|
: 75 10
20 0
15 20

Figure E: Uncheck the 0 value option.

Figure F shows the two single series charts based on the filtered data in column B. Neither displays the
0 value or the category label. However, the chart updates, displaying the O values, when you remove the
filter. On the other hand, if your chart is a one-time task, filtering offers a quick fix. Clear the filter before you

continue.

Replace 0s with NA()

Perhaps the most permanent fix is to replace literal O values with the NA() function using Excel’s Find And
Replace feature. Excel won't chart #N/A values. If the data is updated regularly, you might even enter NA() for

Os from the get-go, which will eliminate the problem altogether. However, that’s not always practical.
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Vendor 1 Vendor 1

= N /
=0/ \ ) -
=/ A

~N

Figure F: The filtered set contains no 0 values in the Vendor 1 column.

First, use Excel’s Replace feature to replace the O values in the example data set with the NA() function:

1. Select the data set (in this case, it's B2:D9).

2. In the Editing group (on the Home tab), click the Sort & Filter option and choose Replace or simply press
Ctrl+H.

3. Enter 0 in the Find What control.
4. Enter =NA() in the Replace control.
5. If necessary, click Options to display additional settings.

6. Check the Match Entire Cell Contents option (Figure G).

Ad A | 8B | € | b T
1 |[Month  Vendor1l Vendor2 Vendor3

2 |lanuary g b 100 .

—] Find and Replace ? X
3 |February 40 40

=z 1 h 19 20 Find Replace

i Marc Findwhat: |0 [ Mo Format set | | Format.. -
5 Apr'll 0 30 Replace with: | =NA] [ Mo Format set | | Format.. -|
6 |May i) 0 Within: | Sheet [+] O waten case

7 ljune 20 75 S [+ Match entire cell contents

?JUIY 13 20 B
g August 32 15 |Rep|amg|| || Replace ‘ | Find Al Hf:mmm ] | Close ‘
10 | (=]

Figure G: Check for 0 values.

7. Click Replace All, and Excel will replace the O values.

8. Click OK to dismiss the confirmation message and then click Close.
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None of the charts display the #N/A values, but the single series charts still display April in the axis and the
legend, which might not matter. If you’re working with the results of formulas that might return O instead of

literal values, you can use an IF() function to return the #N/A error using the following syntax:

=IF (formula=0,NA(), formula)

No panacea

There isn’t an easy one-size-fits-all solution for the challenge of creating O-less charts. If you're displaying
Os for reporting purposes, you might need to maintain two data sets: one for reporting and one for charting.
Removing the category label from the axis dynamically for charting is even harder. On the other hand, if your

requirements aren’t quite so strict, one of the solutions discussed here should be adequate.
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10 ways to reference workbooks and
sheets using VBA

Referencing workbooks and sheets programmatically generates a lot of confusion because there are so many
possibilities. No method is superior; they all have their place. The purpose at hand will define which referencing
method is the most efficient. (You must save your workbook as a macro-enabled workbook, .xlsm, to execute

code.)

1: Reference the active workbook

VBA's ActiveWorkbook property refers to the workbook with the focus. It’'s perfectly acceptable to use this
property to reference the active workbook from code inside the active workbook. However, it’s invaluable
when referencing the active workbook remotely. For example, after passing data to an active workbook, you'd
probably want to save that workbook, which is a simple task for the ActiveWorkbook property. The following

procedures use the ActiveWorkbook property to close the active workbook:
Sub CloseActiveWBNoSave()
'Close the active workbook without saving.
ActiveWorkbook.Close False
End Sub
Sub CloseActiveWBWithSave()
'Close the active workbook and save.
ActiveWorkbook.Close True
End Sub
Sub CloseActiveWB()
'Close the active workbook; let user choose whether to save.
ActiveWorkbook.Close

End Sub

Copyright ©2016 CBS Interactive Inc. All rights reserved.



23

BUILD YOUR EXCEL SKILLS WITH THESE 10 POWER TIPS

This save doesn’t require the workbook’s name, path, and so on. If you need such information, use

ActiveWorkbook’s Path and Name properties as follows:

Function GetActiveWB() As String
GetActiveWB = ActiveWorkbook.Path & "\" & ActiveWorkbook.Name

End Function

2: Reference the workbook that’s running code

ActiveWorkbook evaluates the workbook with the focus; ThisWorkbook refers to the workbook that’s running
the code. The following procedure will return the name of the workbook running the code, which may or may

not be the active workbook:

Function GetThisWB() As String
GetThisWB = ThisWorkbook.Path & "\" & ThisWorkbook.Name

End Function

3: Reference workbooks in the Workbooks collection

The Workbooks collection contains all the open Workbook objects. Using the Workbooks property, you can
refer to open workbooks. For instance, the following procedure populates a list box in a user form with the

names of all open workbooks:

Private Sub UserForm_Activate()
'Populate list box with names of open workbooks.
Dim wb As Workbook
For Each wb In Workbooks
ListBox1.AddItem wb.Name
Next wb
End Sub
Closing all the open workbooks is a bit easier, as the following procedure shows:
Sub CloseAllWB()
'Close all open workbooks.
Workbooks.Close

End Sub
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4: Explicitly reference a workbook

If you know the name of the open workbook you want to reference, an explicit reference might be the most
efficient method. Although an explicit reference is easy, it does require a stable situation. For example, the fol-

lowing procedure activates an open workbook, as determined by the passed string in wbname:
Function ActivateWB(wbname As String)

'Activate wbname; wbname must be open.

Workbooks (wbname) .Activate
End Function
Pass the name of the workbook you want to activate as follows (be sure to include the extension):
ActivateWB("HumanResources.xlsx")

The following function also uses the Workbooks property to determine whether a specific workbook is

currently open
Function IsWBOpen(wbname As String) As Boolean
'Determine if workbook is open.
Dim wb As Workbook
On Error Resume Next
Set wb = Workbooks(wbname)
IsWBOpen = Not wb Is Nothing
End Function

If wbname is open, the function returns True. When not open, the function returns False.

5: Reference workbooks by index

Perhaps the least stable method for referencing a workbook is to use its index value. Excel assigns index
values to workbooks as you open them. The first workbook opened has an index value of 1, the second

workbook opened has an index value of 2, and so on.
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Index values pose a special problem because they change when you delete a Workbook object from the
collection; index values slip down a notch, accordingly. For example, suppose you have three open workbooks

with the following index values:

e HumanResources.xIsx — 1
e (0908002.xlsx - 2

e  ExcelStatisticalFunctions - 3

If a particular task depends on all three workbooks always being open, using the index values can generate

mistakes. For instance, the statement:
Workbooks (1) .Activate

activates HumanResources.xlIsx as long as it’s open. If you close HumanResources.xIsx, the index values for
ExcelStatisticalFunctions and 0908002.xIsx change: ExcelStatisticalFunctions becomes 2 and 0908002.xIsx
becomes 1. As a result, the above statement activates 0908002.xIsx, not HumanResources. That may or may
not be what you want. Using index values to reference workbooks isn’'t wrong, but you must understand the

inherent behaviors to avoid errors that can be difficult to troubleshoot.

6: Reference the active sheet

If you don’t specify an object qualifier, the ActiveSheet property defaults to the active sheet in the active work-

book. For instance, to retrieve the name of the active sheet, you’d use a function similar to the following:
Function GetActiveSheet() As String

GetActiveSheet = ActiveSheet.Name
End Function

This property is read-only; you can’t use it to activate a sheet.

7: Reference Worksheet objects

The Worksheets collection contains all the open sheet objects in a workbook. Using a simple For Each loop,
you can cycle through the collection. For example, the following code populates a list box control with the

names of all the sheets in the active workbook:
Private Sub UserForm_Activate()
'Populate list box with names of sheets
'in active workbook.

Dim ws As Worksheet
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For Each ws In Worksheets
ws.Select
ListBox1l.AddItem ws.Name

Next ws

End Sub

The Sheets and Worksheets collections both contain Worksheet objects, but the Sheets collection contains

both worksheets and chart sheets.

8: Explicitly reference sheets

Use the Worksheets property to explicitly reference a sheet. For instance, use this type of reference to delete a

specific sheet as follows:

Function DeleteSheet(shtname As String)
'Delete shtname.
Application.DisplayAlerts = False
Worksheets(shtname).Delete
Application.DisplayAlerts = True

End Function

9: Reference sheets by index

Index values come in handy when you don’t care about specific sheets, but only their number or order.
Granted, that’s not going to be a common task, but occasionally, referencing by index values can come in

handy. The following procedure adds and deletes sheets based on the number of sheets you want:
Function ControlSheetNumber(intSheets As Integer)

'Add or delete sheets to equal intSheets.

Application.DisplayAlerts = False

'Delete sheets if necessary

While Worksheets.Count > intSheets

Worksheets(1).Delete
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Wend

'Add sheets if necessary

While Worksheets.Count < intSheets
Worksheets.Add

Wend

Application.DisplayAlerts = True

End Function

Use caution when executing this function in an existing workbook because it deletes the first Sheet object in

the collection, even if that sheet contains content. This function is most useful when creating new workbooks

programmatically.

10: Refer to a sheet’s code name property

Code that refers to a Worksheet object by the name on the sheet’s tab runs the risk of generating an error if

you change the sheet’s name. One way to safeguard code is to use the sheet’s code name property in your

code. This property setting is the sheet’s default name, which Excel assigns when you create it: Sheet1,

Sheet2, and so on. Changing the sheet’s name
(displayed by the sheet tab) won’t change the sheet’s

code name.

You must use the Visual Basic Editor (VBE) to view
and change this property; you can’t change it
programmatically. There are two similar properties, so
don’t confuse them. The (Name) property at the top of
the list in the properties window (Figure A) is the code
name. Code names must start with a letter character.
The Name property (without parentheses) toward the
bottom of the list is the name Excel displays on the

sheet tab.

Project - VBAProject

B
5

=& VBAProject (Examplexisx)
B Microsoft Excel Objects

: heetl (List Contral)

heet2 (FINDMID)

48] ThisWorkbook

Properties - Sheet2

) |

| Sheet2 Worksheet
Alphabetic
L || (Mame)

DisplayRightTolLeft False
EnableAutoFilter False
EnableCalculation True
EnableFormatConditions True
EnableOutining False
False

=K sahns
FINDMID

8.38

-1 - xISheetVisible

Figure A: Access the sheet’s code name using the

VBE.
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Use a custom format to display easier-
to-read millions

Large numbers can be difficult to read, especially if there are many of them. To improve readability, you might
want to reduce the number of digits, without losing the number’s scale. For example, the sheet shown in
Figure A shows a lot of large numbers, some in the millions. We can reduce the number of digits using

a custom format, but be careful; you might get some unexpected results! We're specifically working with

millions, but you can apply this technique to any scale.

A A B C D E F

1 Jones g Michaels g Hancock g
2 North £ $17,993,906.00 $1,941,972.00 $2,949,318.00 $1,379,624.00
3 South $141,897.00 $3,901,525.00 $3,031,663.00 $171,178.00
4 East $7,692,284.00 $763,317.00 $1,366,237.00 $182,908.00
5 West $2,643,272.00 $1,089,000.00 $1,559,500.00  $21,253.00
6 Total $28,471,359.00 $7,695,814.00 $8,906,718.00 $1,754,963.00,
7

Figure A: Values with lots of digits can be difficult to read.

Let’s try a custom format and see what happens:

1. Select the data range and

Format Cells 7 =
click the Number group’s
MNumber  Alignment Font Border Fill Protection
launcher (on the Home tab) Clcaig
or press Ctrl+1 to display the e o
C:I::enecry kit
Format Cells dialog. Accounting Type:
2. From the Category list (on Percentage h:mm:ss ~
Fraction m/dfAyyy hemm
the Number tab), choose Scientific mim:ss
Text mm:ss. 0

Custom. Er— | |
[hl:mm:ss

_[§* ##£0);_(5* [#,#20);_(53* ") (@)

_(F#EER0)_I* AR _(F @)
3. Inthe Type control, enter (5% £,#£0,00 );_(5* [£,#£0.00)_(5* 77 (@)
uop g, . _(*#,#20,00 ) _(* = #20.00;,_* -7 _(@ )
the $#,,” M, format string 5% 550,00 v

(Figure B).

Type the number format code, using one of the existing codes as a starting point.

ok || cancel

Figure B: Enter a custom format.

Copyright ©2016




: ! 9 BUILD YOUR EXCEL SKILLS WITH THESE 10 POWER TIPS

4. Click OK to see the formatted results shown in Figure C.

Smith g Jones g Michaels g Hancock g

West $3M S1M $2M SM
Total $28 M $8M $OM $2M

n|~40‘:m.hwm‘—-
m
o
b

Figure C: The formatted values are much easier to read than their full-digit counterparts.

A number format can have up to four sections of code, separated by semicolons. These sections define the

format for positive and negative numbers, zero values, and text using the following syntax:
<positive>;<negative>;<zero>;<text>

In this case, the pound sign combined with the two comma characters displays a character in the millions
position, if one exists. The M component displays a literal M character, to denote millions. There’s a space

before the M to separate it from the value. You can omit the space if you prefer.

Depending on your needs, this simple format code might not be adequate; you might have noticed that there’s
no code for negative values. In fact, if you apply this custom format to a negative value, the format displays
nothing. To accommodate negative values, use a code similar to one of the following:

$H,," MU (84,7 MT);

$#) ) " M"; _$#) ) " M";

$#’,ll M";[Red]$#,," M";

The code following the first semicolon character applies to negative values:

e The first code encloses a negative value in parentheses.
e The second code displays a negative sign before the number.

e The third displays a negative value in red.

If the format is applied before data entry, users must enter the full value for this format to work as expected.
In addition, numbers in the billions and beyond will be displayed in the millions. For instance, the value

$1,000,000,000 displays as $1000 M. Value below one million aren’t displayed at all; $100,000 becomes $ M.

For a comprehensive list of code symbols, see Create or delete a custom number format.
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How to copy a sheet from one
workbook to another

Copying a sheet of data from one workbook to another sounds like a complicated job. In truth, Excel has a
built-in feature that makes quick work of this task—but as usual, there’s more than one way to get the job
done. First, I'll show you Excel’s built-in route. Then, I'll show you a second method, which you might find a bit

easier.

The built-in technique

To copy a sheet from one workbook to another using Excel’s user interface, do the following:

1. Open the source and the target workbook; both workbooks must be open for this method to work. The
source workbook contains the sheet you want to copy or move. You'll move or copy the source sheet to

the target workbook.

2. Right-click the sheet tab in the source workbook and choose Move Or Copy from the resulting shortcut

menu (Figure A).

A

1 Smith g Jones g Michaels g Hancock g
2 North $18 M $2M $3M $1M
3 South SM SAM S3M SM
4 East 7 $8M 1M $1M SM
5 West SM S1M S2 M SM
6 |Total $26M 7 3M $9 M 2™,
7 Rename

= Move or Copy.

8 &1 View Code

il [ Protect Sheet..

97 Tab Color 3
10_ Hide
11 ;e\ectAH Sheets

| List Control | ANDMID | Chart | SUMO [ it —® B ]

Figure A: Select Move Or Copy from the shortcut menu.

3. Inthe Move Or Copy dialog, choose the target sheet from the To Book dropdown (Figure B). Excel will

display only the open workbooks in this list.
4. If necessary, update the Before Sheet selection.

5. If you want to copy rather than move the sheet, click the Create A Copy option at the bottom of the

dialog.

6. Click OK, and Excel will move or copy the sheet to the target workbook.
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An alternate technique b= e G i
Move selected sheets
Now, let’s try a second technique. It's not a shortcut or superior to LEEE
Example.xlsx e
the first method, but you might find it a little more efficient. With both inew book]
Example.xlsx
the source and target workbooks open, do the following: bl L

1. Click the View tab and choose View Side By Side in the Window COUNT

[move to end)

group. Excel will split the screen, horizontally, between the two

"
: Create a copy >
workbooks.

[ ox ]| cance |

2. Drag and drop the sheet tab in the source workbook to the ) .
Figure B: Identify the target workbook.
target workbook to move the source sheet. To copy the sheet

instead of moving it, hold down the Ctrl key while you drag the sheet to the target workbook.

That’s all there is to it!

Worth noting

Excel won’t overwrite a sheet named the same in the target workbook. Instead, it will rename it by adding a

consecutive value to the name.

Moving a sheet isn’t without its problems — problems that might show up later. If either workbook contains an
expression that references the moved or copied sheet, Excel will do its best to find it, returning an error when it

can’t. Similarly, removing a sheet referenced by VBA code will result in a runtime error.
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